Xperia X10a ‘R2B’ firmware update on the agenda

by X10 on June 30, 2010

in Firmware, News

Xperia X10a 'R2B' firmware update on the agendaThe R2BA020 firmware update for Xperia X10i handsets has started its rollout, well at least for UK generic handsets. North American X10a owners, however, are currently wondering when they can get hold of this latest update.

We’ve got no idea on timeline, but judging by the PTCRB website it looks like it can’t be too far away. The site, a third-party certifier, lists several different X10a firmware that were certified in the last few weeks. This includes R2BA021, R2BA023 and R2BA024 firmware. The differences between each aren’t known but are most likely to be tweaks and bug fixes. Given that the last firmware was certified on the 22 June, hopefully it means it is nearing release. It will also be interesting to see whether these updates get extra features over the R2BA020 update. Click through for a screencap.

Xperia X10a 'R2B' firmware update on the agenda

{ 36 comments… read them below or add one }

1 eternity0022 June 30, 2010 at 11:52 AM

can some nice people out there upload the generic UK R2BA020 on any fileservers please? I’m sure many people will appreciate your effort including me 😛

2 Raj June 30, 2010 at 12:07 PM

@eternity0022 If you can’t get the UK R2BA020, then i suggest installing the UK R1FA016 ( SEE Debrand your Xperia X10 [Tutorial]), then do the OTA (Over The Air) update to get the R2BA020 installed.

3 bxandi June 30, 2010 at 12:20 PM

SE ist bullshiting us all -> again!

4 bangster June 30, 2010 at 1:10 PM

Why cant all of us wait for the update from SEUS? hahaha

5 eternity0022 June 30, 2010 at 1:26 PM

@Raj
The problem is that I live in Malaysia and there is no OTA update..I dont think there will ever be 🙁

6 Raj June 30, 2010 at 4:06 PM

@eternity0022 I think you can get the OTA update to work if you set it to use Wifi only, and have the x10 connected to a Wifi network (of course). That’s how I did it

7 Sunny June 30, 2010 at 7:54 PM

I upgraded my software this morning. Everything worked fine and things seemed slightly better, but to my horror, my Swype application does not work any more!! It was so good!
What can I do to overcome this?!?

8 Grospolina June 30, 2010 at 11:22 PM

@Sunny

Swype dies whenever you update the firmware. Just uninstall and reinstall it using the Swype installer program.

9 Sunny July 1, 2010 at 12:08 AM

@Grospolina

Thanks for your help! im back Swyping now!
Its amazing isn’t it! 🙂

10 Sebastian July 1, 2010 at 12:19 AM

Looking at the site, now there’s a new firmware certified “R2BA025 Jun 30, 2010” hope to see it soon.

11 Graham July 1, 2010 at 1:20 AM

My wife’s x10a on 3 Australia is now showing ‘update available’

12 Graham July 1, 2010 at 1:31 AM

But will not update through OTA on the phone.

13 maxpayne July 1, 2010 at 10:14 AM

Any update in India region?

14 Krilok July 1, 2010 at 10:19 AM

1st July, still no update for Spain… I tried the repair procedure twice through PC Companion yesterday evening but all I got was a full reset and still the same ol’ firmware… Why can’t the SE guys just release the darn FW simoultaneously all over the world??? I read earlier the FW’s had to be approved by the corresponding operators before release, but in my case, my operator does’t even allow FW Updates unless done by the SE official service centers (that’s why I’ve had to debrand my phone), so what’s the point of delaying this on and on?

15 bxandi July 1, 2010 at 6:22 PM

1st July, still no update for Austria

16 graham963 July 1, 2010 at 7:01 PM

I’ve just used the repair function on PC companion even though it said I have the up to date software. New version now R2BA020 and I’m sat in a hotel in Bangkok using X10 from UK Orange debranded

17 Roberto July 1, 2010 at 8:29 PM

Still no update for Brazil, and I’m using debranded generic FW R1FB001…

18 zars July 2, 2010 at 5:35 AM

Just installed the update. for some reason i feel its an silly modification they made.. when u try to call someone, earlier u just need to click on the number on the contact.. but now u have to click on that and then it takes u to another dial up screen and there u have to click call.. its a more lengthier process now.. and quite honestly i dont see any improvement in speed.. its still pretty laggy at times.. The only improvement that i do see and one that i think is the best reason to upgrade is that it somehow improves the battery life.. quite considerably.. So happy upgrading..

19 Alex Lai @ HKSAR July 2, 2010 at 7:44 AM

2nd July OTA update avaliable

20 bxandi July 2, 2010 at 10:51 AM

2nd July, Austria unbranded phone (original) no update! these bull…… from SE!

21 eiabea July 2, 2010 at 7:31 PM

@bxandi: i think we in austria will be the last xD
thank god, we have root, so why waiting for the official update??

22 Abhi July 2, 2010 at 9:10 PM

@graham963 do you mean repair worked and updated you firmware?

23 Sebastian July 2, 2010 at 10:42 PM

I just got the update via SEUS for my X10a Generic FW!

24 Dima July 3, 2010 at 2:12 AM

@ Sebastian
what version of generic FW for your X10a did you have before the update?
R1FB001 BR or R1BA016 AR ?

25 Sebastian July 3, 2010 at 2:30 AM

@Dima
I had North America Generic X10a Firmware R1FA014
I debranded my phone using this site’s tutorial (and files) last week.

26 pat July 3, 2010 at 3:58 AM

@Sebastian
Did u use the PC compagnion or the ota via wifi?

27 Dav July 3, 2010 at 5:06 AM

I got it on my Rogers phone earlier today! (though the updater on the computer)

28 pat July 3, 2010 at 5:52 AM

I have debranded my xperia and I am using it with at&t. So that means I have to put it back to Rogers?

29 Sebastian July 3, 2010 at 7:01 AM

@pat
I used Update Service software for PC.

30 pat July 3, 2010 at 7:07 AM

Mine is saying that u have the latest software.

31 pa July 3, 2010 at 7:30 AM

Finally

32 Patrick July 3, 2010 at 9:18 AM

Hello!
is there any way to get a working copy of swype! the one I have says that my license is out 🙁
And does anyone know when the new firmware will arrive to sweden? my phone is not branded.

33 Tamas Bojtor July 4, 2010 at 12:51 AM

Anyone experiencing problems with the market after the latest update? Many of my paid apps are not showing up…a developer emailed me saying copyright protected apps will not show up until SE and Google confirm with each other the update they just rolled out to us…This is so annoying… Any ideas how to get our paid apps back again?!?

34 Bakul Bhandari ( India ) July 8, 2010 at 7:53 AM

I have just upgraded my software through Wi-fi and i am yet to see changes in my x10 .

35 Steve July 14, 2010 at 9:26 AM

I have a Experia X10a (3 AU branded) in the UK and awaiting the update with baited breath.. Baseband version 1.0.14 Build R1FA014

ANy idea when I can update – Phone keeps saying I have latest software..

36 rich July 15, 2010 at 7:31 PM

just got the update at last
in switzerland
update was to firmware 1.6
build number R2BA024

Leave a Comment

{ 2 trackbacks }

Previous post:

Next post:

Sitemap